We're Hiring! Click here for more

Open Source Dependencies

Last modified: April 2020
Last modified: April 2020

Unum ID uses open source software as part of its products. The following lists exactly what those dependencies are, separated by product. "Backend" refers to code that services all products.

Backend (Unum ID Service)
NPM Modules

  • @feathersjs/adapter-commons ^4.5.2
  • @feathersjs/configuration ^4.5.2
  • @feathersjs/errors ^4.5.2
  • @feathersjs/express ^4.5.2
  • @feathersjs/feathers ^4.5.2
  • @feathersjs/socketio ^4.5.2
  • @feathersjs/transport-commons ^4.5.2
  • aws-sdk ^2.599.0
  • axios ^0.19.0
  • compression ^1.7.4
  • cors ^2.8.5
  • dotenv ^8.2.0
  • eosjs-ecc ^4.0.7
  • feathers-hooks-common ^5.0.2
  • feathers-mikro-orm https://github.com/UnumID/feathers-mikro-orm.git
  • helmet ^3.20.0
  • is-url ^1.2.4
  • json-stable-stringify ^1.0.1
  • lodash ^4.17.15
  • mikro-orm ^3.6.9
  • nodemailer ^6.4.5
  • pem-file ^1.0.1
  • pg ^7.12.1
  • qrcode ^1.4.4
  • serve-favicon ^2.5.0
  • twilio ^3.37.1
  • uuid ^3.3.3
  • winston ^3.2.1
  • winston-syslog ^2.4.4
  • @types/compression ^1.0.1
  • @types/cors ^2.8.6
  • @types/helmet ^0.0.45
  • @types/is-url ^1.2.28
  • @types/jest ^24.0.22
  • @types/json-stable-stringify ^1.0.32
  • @types/lodash ^4.14.149
  • @types/nodemailer ^6.4.0
  • @types/qrcode ^1.3.4
  • @types/serve-favicon ^2.2.31
  • @types/uuid ^3.4.6
  • @types/winston-syslog ^2.0.2
  • @typescript-eslint/eslint-plugin ^2.7.0
  • @typescript-eslint/parser ^2.7.0
  • eslint ^6.6.0
  • eslint-config-airbnb ^18.0.1
  • eslint-import-resolver-typescript ^2.0.0
  • eslint-plugin-import ^2.18.2
  • jest ^24.9.0
  • mockdate ^2.0.5
  • nodemon ^1.19.1
  • shx ^0.3.2
  • ts-jest ^24.1.0
  • ts-node-dev ^1.0.0-pre.44
  • tslint ^5.19.0
  • typescript ^3.5.3

Docker Images

  • node:12-alpine

CircleCI Orbs

  • circleci/node:12.7.0
  • circleci/aws-cli@0.1.22
  • circleci/aws-eks@0.2.3
  • circleci/kubernetes@0.4.0

Backend (Hyperledger)
NPM Modules

  • body-parser ^1.19.0
  • cors ^2.8.5
  • express ^4.17.1
  • fabric-ca-client ~1.4.0
  • fabric-network ~1.4.0
  • md5 ^2.2.1
  • request ^2.88.0
  • uuid ^7.0.2
  • winston ^3.2.1
  • winston-syslog ^2.4.4
  • @types/chai ^4.1.7
  • @types/mocha ^5.2.5
  • @types/node ^10.17.19
  • @types/sinon ^5.0.7
  • @types/sinon-chai ^3.2.1
  • @types/winston-syslog ^2.0.2
  • chai ^4.2.0
  • mocha ^5.2.0
  • nodemon ^1.19.1
  • nyc ^13.1.0
  • sinon ^7.1.1
  • sinon-chai ^3.3.0
  • ts-node ^7.0.1
  • tslint ^5.11.0
  • typescript ^3.1.6

Docker Images

  • node:12-alpine

CircleCI Orbs

  • circleci/node:12.7.0
  • circleci/aws-cli@0.1.22
  • circleci/aws-eks@0.2.3
  • circleci/kubernetes@0.4.0

Backend (TRON)
NPM Modules

  • body-parser ^1.19.0
  • dotenv ^8.1.0
  • express ^4.17.1
  • express-bearer-token ^2.4.0
  • node-cron ^2.0.3
  • nodemailer ^6.3.0
  • pg ^7.12.1
  • ssl-root-cas ^1.3.1
  • tronweb ^2.6.3
  • uuid ^3.4.0
  • winston ^3.2.1
  • winston-syslog ^2.4.4
  • eslint ^6.8.0
  • eslint-config-airbnb ^18.0.1
  • eslint-plugin-import ^2.20.0
  • jest ^25.1.0

Docker Images

  • node:12-alpine

CircleCI Orbs

  • circleci/node:12.7.0
  • circleci/aws-cli@0.1.22
  • circleci/aws-eks@0.2.3
  • circleci/kubernetes@0.4.0

Backend (Issuer)
NPM Modules

  • @feathersjs/configuration ^4.3.0
  • @feathersjs/errors ^4.3.0
  • @feathersjs/express ^4.3.0
  • @feathersjs/feathers ^4.3.0
  • @feathersjs/transport-commons ^4.4.1
  • @types/lodash ^4.14.149
  • axios ^0.19.0
  • compression ^1.7.4
  • cors ^2.8.5
  • dotenv ^8.2.0
  • eosjs-ecc ^4.0.7
  • feathers-hooks-common ^4.20.7
  • feathers-mikro-orm https://github.com/UnumID/feathers-mikro-orm.git
  • helmet ^3.20.0
  • lodash ^4.17.15
  • mikro-orm ^3.0.0-rc.2
  • pem-file ^1.0.1
  • pg ^7.14.0
  • serve-favicon ^2.5.0
  • uuid ^3.3.3
  • winston ^3.2.1
  • winston-syslog ^2.4.4
  • @types/compression ^1.0.1
  • @types/cors ^2.8.6
  • @types/dotenv ^8.2.0
  • @types/helmet ^0.0.45
  • @types/jest ^24.0.23
  • @types/serve-favicon ^2.5.0
  • @types/uuid ^3.4.6
  • @types/winston-syslog ^2.0.2
  • @typescript-eslint/eslint-plugin ^2.10.0
  • @typescript-eslint/parser ^2.10.0
  • eslint ^6.7.2
  • eslint-config-airbnb ^18.0.1
  • eslint-import-resolver-typescript ^2.0.0
  • eslint-plugin-import ^2.18.2
  • jest ^24.9.0
  • mockdate ^2.0.5
  • nodemon ^1.19.1
  • shx ^0.3.2
  • ts-jest ^24.2.0
  • ts-node ^8.5.4
  • ts-node-dev ^1.0.0-pre.44
  • tslint ^5.19.0
  • typescript ^3.5.3

Docker Images

  • node:12-alpine

CircleCI Orbs

  • circleci/node:12.7.0
  • circleci/aws-cli@0.1.22
  • circleci/aws-eks@0.2.3
  • circleci/kubernetes@0.4.0

Backend (ACME Server)
NPM Modules

  • @feathersjs/authentication ^4.4.3
  • @feathersjs/configuration ^4.3.0
  • @feathersjs/errors ^4.3.0
  • @feathersjs/express ^4.3.0
  • @feathersjs/feathers ^4.3.0
  • @feathersjs/socketio ^4.3.0
  • @feathersjs/transport-commons ^4.3.11
  • axios ^0.19.0
  • compression ^1.7.4
  • cors ^2.8.5
  • dotenv ^8.2.0
  • feathers-hooks-common ^5.0.2
  • feathers-mikro-orm https://github.com/UnumID/feathers-mikro-orm.git
  • helmet ^3.20.0
  • lodash ^4.17.15
  • mikro-orm ^3.4.0
  • pg ^7.14.0
  • semver ^7.1.3
  • serve-favicon ^2.5.0
  • uuid ^3.3.3
  • validator ^12.2.0
  • winston ^3.2.1
  • winston-syslog ^2.4.4
  • @types/compression ^1.0.1
  • @types/cors ^2.8.6
  • @types/helmet ^0.0.45
  • @types/jest ^24.0.23
  • @types/lodash ^4.14.149
  • @types/semver ^7.1.0
  • @types/serve-favicon ^2.5.0
  • @types/uuid ^3.4.6
  • @types/validator ^12.0.1
  • @types/winston-syslog ^2.0.2
  • @typescript-eslint/eslint-plugin ^2.8.0
  • @typescript-eslint/parser ^2.8.0
  • eslint ^6.7.0
  • eslint-config-airbnb ^18.0.1
  • eslint-import-resolver-typescript ^2.0.0
  • eslint-plugin-import ^2.18.2
  • jest ^24.9.0
  • nodemon ^1.19.1
  • shx ^0.3.2
  • ts-jest ^24.2.0
  • ts-node-dev ^1.0.0-pre.44
  • tslint ^5.19.0
  • typescript ^3.5.3

Docker Images

  • node:12-alpine

CircleCI Orbs

  • circleci/node:12.7.0
  • circleci/aws-cli@0.1.22
  • circleci/aws-eks@0.2.3
  • circleci/kubernetes@0.4.0

Backend (ACME Client)
NPM Modules

  • @feathersjs/authentication-client ^4.4.3
  • @feathersjs/client ^4.3.11
  • @feathersjs/feathers ^4.3.11
  • @feathersjs/rest-client ^4.3.11
  • @feathersjs/socketio-client ^4.3.11
  • @fortawesome/fontawesome-svg-core ^1.2.27
  • @fortawesome/free-solid-svg-icons ^5.12.1
  • @fortawesome/react-fontawesome ^0.1.8
  • @testing-library/react ^9.4.1
  • @types/jest 24.0.23
  • @types/node 12.12.12
  • @types/react 16.9.13
  • @types/react-dom 16.9.4
  • axios ^0.19.0
  • classcat ^4.0.2
  • react ^16.12.0
  • react-dom ^16.12.0
  • react-loader-spinner ^3.1.5
  • react-router-dom ^5.1.2
  • react-scripts 3.2.0
  • socket.io-client ^2.3.0
  • typeface-lato ^0.0.75
  • typeface-open-sans ^0.0.75
  • typeface-playfair-display ^1.1.4
  • typescript 3.7.2
  • uuid ^3.3.3
  • validator ^12.2.0
  • @testing-library/react-hooks ^3.2.1
  • @types/enzyme ^3.10.4
  • @types/react-loader-spinner ^3.1.0
  • @types/react-router-dom ^5.1.3
  • @types/uuid ^3.4.6
  • @types/validator ^12.0.1
  • @typescript-eslint/eslint-plugin ^2.9.0
  • @typescript-eslint/parser ^2.9.0
  • enzyme ^3.10.0
  • enzyme-adapter-react-16 ^1.15.1
  • eslint ^6.7.1
  • eslint-config-airbnb ^18.0.1
  • eslint-import-resolver-typescript ^2.0.0
  • eslint-plugin-import ^2.18.2
  • eslint-plugin-jsx-a11y ^6.2.3
  • eslint-plugin-react ^7.16.0
  • eslint-plugin-react-hooks ^2.3.0
  • jest-useragent-mock ^0.0.3

Docker Images

  • node:12-alpine

CircleCI Orbs

  • circleci/node:12.7.0
  • circleci/aws-cli@0.1.22
  • circleci/aws-eks@0.2.3
  • circleci/kubernetes@0.4.0

ACME Mobile App
NPM Modules

  • @react-native-community/async-storage ^1.7.1
  • @react-native-community/masked-view ^0.1.6
  • @react-navigation/bottom-tabs ^5.0.0
  • @react-navigation/native ^5.0.0
  • @react-navigation/stack ^5.0.0
  • @sentry/react-native ^1.2.2
  • axios ^0.19.2
  • eosjs-ecc ^4.0.7
  • eosjs-ecc-rn ^4.0.6-rn
  • expo ~36.0.0
  • hybrid-crypto-js ^0.2.2
  • lodash ^4.17.15
  • native-base ^2.13.8
  • node-forge ^0.9.1
  • pem-file ^1.0.1
  • prop-types ^15.7.2
  • react ~16.9.0
  • react-dom ^16.12.0
  • react-native ~0.61.4
  • react-native-branch ^4.3.0
  • react-native-camera ^3.17.0
  • react-native-check-box ^2.1.7
  • react-native-crypto-js ^1.0.0
  • react-native-dismiss-keyboard ^1.0.0
  • react-native-gesture-handler ~1.5.0
  • react-native-iphone-x-helper ^1.2.1
  • react-native-material-ripple ^0.9.1
  • react-native-mixpanel ^1.1.14
  • react-native-onesignal ^3.6.4
  • react-native-permissions ^2.0.9
  • react-native-popup-dialog ^0.18.3
  • react-native-qrcode-scanner ^1.3.1
  • react-native-reanimated ~1.4.0
  • react-native-safe-area-context ^0.7.3
  • react-native-screens ~2.0.0-alpha.12
  • react-native-sensitive-info ^5.5.5
  • react-native-spinkit ^1.5.0
  • react-native-splash-screen ^3.2.0
  • react-native-svg ^11.0.1
  • react-native-swiper ^1.6.0-nightly.5
  • react-native-touch-id ^4.4.1
  • react-native-unimodules ~0.7.0
  • react-native-web ~0.11.7
  • react-navigation ^4.1.1
  • react-navigation-stack ^2.1.1
  • react-redux ^7.1.3
  • redux ^4.0.5
  • redux-logger ^3.0.6
  • redux-persist ^6.0.0
  • redux-persist-sensitive-storage ^1.0.0
  • redux-persist-transform-encrypt ^2.0.1
  • redux-thunk ^2.3.0
  • url ^0.11.0
  • url-search-params-polyfill ^8.0.0
  • @babel/core ^7.0.0
  • @babel/runtime ^7.8.4
  • @testing-library/react-native ^5.0.3
  • babel-eslint ^10.0.3
  • babel-jest ^25.1.0
  • babel-preset-expo ~8.0.0
  • enzyme ^3.11.0
  • enzyme-adapter-react-16 ^1.15.2
  • eslint ^6.8.0
  • eslint-config-airbnb ^18.0.1
  • eslint-plugin-import ^2.20.1
  • eslint-plugin-jsx-a11y ^6.2.3
  • eslint-plugin-react ^7.18.3
  • jest ^25.1.0
  • jest-expo ^36.0.1
  • jest-fetch-mock ^3.0.1
  • metro-react-native-babel-preset ^0.58.0
  • react-test-renderer ^16.12.0

Cocoa Pods

  • OneSignal >=2.9.3 < 3.0

Contact Us

Headquarters

2 Embarcadero Center
#9135
San Francisco, CA 94111
United States

Email us